记忆化搜索—— FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.

The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
首先我们需要知道记忆化搜索的模板:

f(problem p){
    
    
    if(p has been solved){
    
    
         return the result      
    }else{
    
    
         divide the p into some sub-problems (p1, p2, p3...)
         f(p1);
         f(p2);
         f(p3);
         ...
    }

那么很显然这是一道记忆化搜索的模板题
code:

#include<iostream>
#include<algorithm>
using namespace std;
int n,k;
int dp[110][110];
int a[110][110];
int dir[4][2] = {
    
    {
    
    -1,0},{
    
    0,-1},{
    
    1,0},{
    
    0,1}};
int dfs(int x,int y){
    
    
	if(dp[x][y]>0) return dp[x][y];//if it has been solved ,return
	int maxn = 0;
	for(int i=0;i<4;i++)
	{
    
    
		for(int j=1;j<=k;j++)
		{
    
    
			int dx = x+dir[i][0]*j;
			int dy = y+dir[i][1]*j;
			if(dx>=0&&dx<n&&dy<n&&dy>=0&&a[x][y]<a[dx][dy]){
    
    
				int tmp = dfs(dx,dy);//divied it into several problems
				maxn = max(maxn,tmp);
			}
		}
	}
	dp[x][y] = maxn+a[x][y];//it has been solved
	
	return dp[x][y];//return the solved-results
}
int main()
{
    
    
	while(~scanf("%d%d",&n,&k))	
	{
    
    		
		if(k==-1) break;		
		for(int i=0;i<n;i++)	
			for(int j=0;j<n;j++){
    
    		
				scanf("%d",&a[i][j]);		
				dp[i][j]=0;		
			}		
		dfs(0,0);		
		cout<<dp[0][0]<<endl;	
	}	
	return 0;

} 

猜你喜欢

转载自blog.csdn.net/naiue/article/details/105451930