C语言字符串-字符串排序

7-3字符串排序 (20分)

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue green white

输出样例:

After sorted:
blue
green
red
white
yellow

#include<stdio.h>
#include<string.h>
int main()
{
    
    
	char str[5][100] = {
    
     0 };
	char tem[100];
	for (int i = 0; i<5; i++)
	{
    
    
		scanf("%s", str[i]);
	}
	for (int i = 0; i<4; i++)
	{
    
    
		for (int j = 0; j<4 - i; j++)
		{
    
    
			if (strcmp(str[j], str[j + 1])>0)
			{
    
    
				strcpy(tem, str[j]);
				strcpy(str[j], str[j + 1]);
				strcpy(str[j + 1], tem);
			}
		}
	}
	printf("After sorted:\n");
	for (int i = 0; i<5; i++)
	{
    
    
		printf("%s\n", str[i]);
	}
	return 0;
}

冒泡排序即可,不过不同的一点是,字符串交换要用strcpy和strcmp,想数一样用=是不匹配的

猜你喜欢

转载自blog.csdn.net/weixin_51198300/article/details/111596887