HDOJ_1.3.4——排名

题目:

排名

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6532 Accepted Submission(s): 1983
 

Problem Description

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。

Input

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。

Output

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。

Sample Input

4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output

3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

Hint

Huge input, scanf is recommended.
 

Source

浙大计算机研究生复试上机考试-2005年

Recommend

JGShining

C++代码:

#include<iostream>
#include<string>
using namespace std;
int main(){
	//N为考生人数(为0结束),M为考题数,G为分数线
	int N,M,G;
	//i,j为循环变量,m为考生解决的题目总数,question_num为考生解决的考题号
	int i,j,m,question_num;
	//考生准考证号
	string id;
	while(cin>>N){
		if(N==0){
			break;
		}else{
			//记录每场考试的题目分值(因为每场考试题目数量不一定相同所以每场考试都要重新定义,最多10道题,从1开始则数组大小为11)
			int question_score[11];
			//记录及格考生人数
			int sum=0;
			cin>>M;
			cin>>G;
			//及格学生的信息
			string good_student_id[1000];
			int good_student_score[1000];
			//输入考题的正整数分值
			for(i=1;i<=M;i++){
				cin>>question_score[i];
			}
			//对每个考生进行处理
			for(i=0;i<N;i++){
				int sum_score=0;
				cin>>id;
				cin>>m;
				for(j=0;j<m;j++){
					cin>>question_num;
					sum_score+=question_score[question_num];
				}
				//存储及格学生信息
				if(sum_score>=G){	
					//注意:要用sum作为下标,不能用i,因为i不是连续变化的
					good_student_id[sum]=id;
					good_student_score[sum]=sum_score;
					sum+=1;
				}
			}

			//冒泡排序(注意:对对及格学生排序)
			int temp1;
			string temp2;
			for(i=0;i<sum-1;i++){
				for(j=0;j<sum-i-1;j++){
					if(good_student_score[j]<good_student_score[j+1]){
						//交换score
						temp1=good_student_score[j];
						good_student_score[j]=good_student_score[j+1];
						good_student_score[j+1]=temp1;
						//交换id
						temp2=good_student_id[j];
						good_student_id[j]=good_student_id[j+1];
						good_student_id[j+1]=temp2;
					}else if(good_student_score[j]==good_student_score[j+1]){
						if(good_student_id[j]>good_student_id[j+1]){
							//分数相同只交换id就行
							temp2=good_student_id[j];
							good_student_id[j]=good_student_id[j+1];
							good_student_id[j+1]=temp2;	
						}
					}
				}
			}
			//输出及格学生的信息
			cout<<sum<<endl;
			for(i=0;i<sum;i++){
				cout<<good_student_id[i]<<" "<<good_student_score[i]<<endl;
			}
		}
	}
	return 0;
}

运行结果:

猜你喜欢

转载自blog.csdn.net/qq_41137110/article/details/103160329
今日推荐