OJ Problem 3445 C#委托、类和事件的验证

题目描述

程序由两部分组成,如下代码所示。第一部分定义了委托、类和事件。第二部分进行验证。  

using System;
namespace HelloWorldApplication
{
    public delegate void DelegateRing();
    public class Bell{
        public event DelegateRing Ring;
        public void OnRing(){ Ring(); }
    }
/
            
            请填写代码

/
    class HelloWorld
    {
        static void Main(string[] args)
        {
            try{
                Teacher teacher = new Teacher();
                teacher.Register(new Bell());
                Student student = new Student();
                student.Register(new Bell());
                Console.ReadKey();
            }
            catch(Exception ex)
            {
                Console.WriteLine(ex.Message);
            }
        }
    }
}

输入

无输入

输出

验证事件输出 

样例输入

样例输出

teacher
student
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Security.Cryptography;
using System.IO;
namespace ConsoleApplication1
{
    public delegate void DelegateRing();
    public class Bell
    {
        public event DelegateRing Ring;
        public void OnRing() { Ring(); }
    }
    class Teacher
    {
        public void Register(Bell bell)
        {
            bell.Ring += new DelegateRing(HandleEvent);
            bell.OnRing();
        }
        public void HandleEvent()
        {
            Console.WriteLine("teacher");
        }
    }
    class Student
    {
        public void Register(Bell bell)
        {
            bell.Ring += new DelegateRing(HandleEvent2);
            bell.OnRing();
        }
        public void HandleEvent2()
        {
            Console.WriteLine("student");
        }
    }
    class Program
    {
        static void Main(string[] args)
        {
            try
            {
                Teacher teacher = new Teacher();
                teacher.Register(new Bell());
                Student student = new Student();
                student.Register(new Bell());
                Console.ReadKey();
            }
            catch (Exception ex)
            {
                Console.WriteLine(ex.Message);
            }
        }
    }
} 

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/105114035