Redundant Paths

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample:

One visualization of the paths is: 1 2 3 +—+—+ | | | | 6 +—+—+ 4 / 5 / / 7 + Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 1 2 3 +—+—+
| |
| |
6 +—+—+ 4
/ 5 :
/ :
/ :
7 + - - - -
Check some of the routes:
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
Every pair of fields is, in fact, connected by two routes.

It’s possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

题目大意

给你一个无向图,求加上多少条边,使此图成为边的双连通图

思路

第一步,缩点。

不难发现,只要把叶子节点连起来即可

代码

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=5077*2;
int a[maxn],b[maxn],list[maxn*2],low[maxn*2],dfn[maxn*2],next[maxn*2],f[maxn];
int n,m,cnt,ccnt,ass;
struct E
{
    int to,next;
}e[maxn+9];
void add(int u,int v)
{
    e[++cnt].to=v; e[cnt].next=list[u]; list[u]=cnt;
    a[cnt]=u; b[cnt]=v;
}
void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++ccnt;
    for(int i=u; i; i=next[i])
    {
        int v=e[i].to;
        if(!dfn[v])
        {
            tarjan(v,u); low[u]=min(low[u],low[v]);
        }
        if(v!=pre)low[u]=min(low[u],dfn[v]);
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        add(x,y); add(y,x);
    }
    for(int i=1; i<=n; i++) if(!dfn[i]) tarjan(i,0);
    for(int i=1; i<=cnt; i++) 
    if(low[a[i]]!=low[b[i]]) f[low[b[i]]]++;
    for(int i=1; i<=n; i++) if(f[i]==1) ass++;
    printf("%d",(ass+1)/2);
}









猜你喜欢

转载自blog.csdn.net/eric1561759334/article/details/80423762