hdu2006——求奇数的乘积

给你n个整数,求他们中所有奇数的乘积。
Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。
Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
Sample Input
3 1 2 3
4 2 3 4 5
Sample Output
3
15

大水题一道
代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=10050;
int main(void){
    int n;
    while(~scanf("%d",&n)){
        long long ans=1;
        int t;
        for(int i=0;i<n;i++){
            scanf("%d",&t);
            if(t%2==1){
                ans*=t;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/westbrook1998/article/details/80516088