PAT甲级---1005 Spell It Right (20 分)

PAT甲级—1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
100
).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

#include<iostream>
#include<cstring>
#include<string>
using namespace std;

string c[10]={
    
    "zero","one","two","three","four","five","six","seven","eight","nine"};

int main(){
    
    
	char a[105];
	while(gets(a))
	{
    
    
		int len=strlen(a);
		int sum=0;
		for(int i=0;i<len;i++){
    
    
			sum+=a[i]-'0';
		}
		
		string b=to_string(sum);
		
		int len2=b.length();
		for(int i=0;i<len2;i++){
    
    
			printf("%s",c[b[i]]);
		}
	}
	
	return 0;
}

无法编译,原因未知
参考答案

#include <iostream>
using namespace std;
int main() {
    
    
    string a;
    cin >> a;
    int sum = 0;
    for (int i = 0; i < a.length(); i++)
        sum += (a[i] - '0');
    string s = to_string(sum);
    string arr[10] = {
    
    "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    cout << arr[s[0] - '0'];
    for (int i = 1; i < s.length(); i++)
        cout << " " << arr[s[i] - '0'];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44411458/article/details/123221860