pat-1094. The Largest Generation (25)

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:

9 4

简单题 层序遍历即可

#include<iostream>
#include<queue>
#include<vector>

using namespace std;

int main(){
  int n,m,high=0,max=0,level=0;
  int arr[101]={0};

cin>>n>>m;
  vector<int> *v;
  v=new vector<int> [n+2];

  for(int i=0;i<m;i++)
  {
    int nn,k,d;
    cin>>nn;
    cin>>k;
    for(int j=0;j<k;j++)
      cin>>d,v[nn].push_back(d),arr[d]=1;
  }
  int h;
  for(int i=1;i<=n;i++)
    if(arr[i]==0) h=i;
  //cout<<"ok"<<h<<endl;
  queue<int> q;
  int t1,num=0,temp=0;
  q.push(h);
  q.push(-1);
  while(!q.empty())
  {
    t1=q.front();
    q.pop();
    if(t1==-1){
      high++;
      if(num>max) max=num,level=high;
      if(q.empty()) break; 
      q.push(-1);num=0;
      continue;
    }
    num++;
    for(int i=0;i<v[t1].size();i++)
      q.push(v[t1][i]);
  }
  cout<<max<<" "<<level;
}


猜你喜欢

转载自blog.csdn.net/var1994/article/details/52461606