2018年蓝桥杯省赛C/C++ A组 题目6 航班时间


标题:航班时间

【问题背景】
小h前往美国参加了蓝桥杯国际赛。小h的女朋友发现小h上午十点出发,上午十二点到达美国,于是感叹到“现在飞机飞得真快,两小时就能到美国了”。

小h对超音速飞行感到十分恐惧。仔细观察后发现飞机的起降时间都是当地时间。由于北京和美国东部有12小时时差,故飞机总共需要14小时的飞行时间。

不久后小h的女朋友去中东交换。小h并不知道中东与北京的时差。但是小h得到了女朋友来回航班的起降时间。小h想知道女朋友的航班飞行时间是多少。

【问题描述】
对于一个可能跨时区的航班,给定来回程的起降时间。假设飞机来回飞行时间相同,求飞机的飞行时间。

【输入格式】
从标准输入读入数据。
一个输入包含多组数据。

输入第一行为一个正整数T,表示输入数据组数。
每组数据包含两行,第一行为去程的 起降 时间,第二行为回程的 起降 时间。
起降时间的格式如下

h1:m1:s1 h2:m2:s2

h1:m1:s1 h3:m3:s3 (+1)

h1:m1:s1 h4:m4:s4 (+2)
表示该航班在当地时间h1时m1分s1秒起飞,

第一种格式表示在当地时间 当日 h2时m2分s2秒降落
第二种格式表示在当地时间 次日 h3时m3分s3秒降落。
第三种格式表示在当地时间 第三天 h4时m4分s4秒降落。

对于此题目中的所有以 h:m:s 形式给出的时间, 保证 ( 0<=h<=23, 0<=m,s<=59 ).

【输出格式】
输出到标准输出。

对于每一组数据输出一行一个时间hh:mm:ss,表示飞行时间为hh小时mm分ss秒。
注意,当时间为一位数时,要补齐前导零。如三小时四分五秒应写为03:04:05。

【样例输入】
3
17:48:19 21:57:24
11:05:18 15:14:23
17:21:07 00:31:46 (+1)
23:02:41 16:13:20 (+1)
10:19:19 20:41:24
22:19:04 16:41:09 (+1)

【样例输出】
04:09:05
12:10:39
14:22:05

【限制与约定】
保证输入时间合法,飞行时间不超过24小时。


资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗  < 1000ms


请严格按要求输出,不要画蛇添足地打印类似:“请您输入...” 的多余内容。

注意:
main函数需要返回0;
只使用ANSI C/ANSI C++ 标准;
不要调用依赖于编译环境或操作系统的特殊函数。
所有依赖的函数必须明确地在源文件中 #include <xxx>
不能通过工程设置而省略常用头文件。

提交程序时,注意选择所期望的语言类型和编译器类型。

思路:题目不难,在我看来有主要是设计字符串的问题,先把给出的时间全部换成秒,我们可以通过一个拟定方程来求解:假设t为相差的时差,time为飞行时间,即statt1 + time + t = end1,statt2 + time - t = end2;这样时区差就可以直接忽略掉,直接上代码:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <ctype.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
#define maxn 10005
using namespace std;
const int day = 24*60*60;
const int hour = 60*60;
const int mintes = 60;

int input1()
{
    int a,b,c;
    scanf("%d:%d:%d",&a,&b,&c);
    int time = a*hour + b*mintes + c;
    return time;
}

int input2()
{
    int a,b,c;
    scanf("%d:%d:%d",&a,&b,&c);
    int time = a*hour + b*mintes + c;
    char ch,cn;
    while( (ch = getchar())!='\n' && ch != '\r' )
    {
        if(ch == '(')
        {
            getchar();  //用来把+号吸收掉 
            cn = getchar(); //用来接收天数 
            time = time + (cn - '0')*day;
        }
    } 
    return time;
}

void print(int time)
{
    int a,b,c;
    a = time/hour;
    time = time % hour;
    b = time / mintes;
    time = time % mintes;
    c = time;
    printf("%02d:%02d:%02d\n",a,b,c);
}

int main()
{
    int h1,m1,s1,h2,m2,s2;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int start1 = input1();
        int end1 = input2();
        int start2 = input1();
        int end2 = input2();
        int ans = 0;
        ans = (end1 - start1) + (end2 - start2);
        print(ans/2);
    }
    
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiaoning9299/article/details/88560290