poj2631 Roads in the North(树的直径模板)

Roads in the North
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3419   Accepted: 1688

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

Source


题解:

求树的直径模板。

树的直径是指树的最长简单路。求法: 两遍BFS :先任选一个起点BFS找到最长路的终点,再从终点进行BFS,则第二次BFS找到的最长路即为树的直径。

这样显然是对的(博主本人刚刚已经自己证明过了)


代码:

#include <iostream>  
#include <fstream>  
#include <cstdio>  
#include <cmath>  
#include <map>  
#include <set>  
#include <bitset>  
#include <ctime>  
#include <cstring>  
#include <algorithm>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <list> 
using namespace std;
int tot,n,now,mx,jia[100001],e[100001],head[100001],next[100001],dis[100001];
void build(int t,int k,int s){
	tot++;
	e[tot]=k;jia[tot]=s;
	next[tot]=head[t];head[t]=tot;
}
void dfs(int x,int fa,int lu){
	int i;
	dis[x]=lu;
	for(i=head[x];i;i=next[i]){
		if(e[i]==fa)continue;
		dfs(e[i],x,lu+jia[i]);
	}
}
int main(){
	int t,k,s,i;
	while(~scanf("%d%d%d",&t,&k,&s)){
		//printf("%d %d %d\n",t,k,s);
		n=max(n,max(t,k));
		build(t,k,s);
		build(k,t,s);
	}
	dfs(1,0,0);
	for(i=1;i<=n;i++)
	 if(dis[i]>mx){
	 	mx=dis[i];
	 	now=i;
	 }
	//printf("%d\n",now); 
	memset(dis,0,sizeof(dis)); 
	dfs(now,0,0);
	mx=0;
	for(i=1;i<=n;i++)
	 if(dis[i]>mx){
	 	mx=dis[i];
	 }
	printf("%d",mx); 
}

猜你喜欢

转载自blog.csdn.net/qq_41510496/article/details/80693988