问题 : Decimal integer conversion

问题 : Decimal integer conversion

时间限制: 1 Sec   内存限制: 128 MB
http://218.198.32.182/problem.php?cid=1071&pid=4

题目描述

XiaoMing likes mathematics, and he is just learning how to convert numbers between different
bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a
number to a new base and writes down the result, he always writes one of the digits wrong.
For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be
"1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or
deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she
gets wrong.
Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine
the correct original value of N (in base 10). (N<=10^10)
You can assume N is at most 1 billion, and that there is a unique solution for N.

输入

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)
Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.

输出

For each test case generate a single line containing a single integer ,  the correct value of N

样例输入

1
1010
212

样例输出

14
就是每次输出有两行。第一行是一个二进制串,第二行是一个三进制串,然后没一行有一个是错误的,找出错误的那个数,然后改为正确的相比较,输出最大的。
样例解析:  1010   第二个0改为1后化为10进制为  14  212将第一个改为1后化为10进制后也为 14
所以输出14, 如果有多个,输出最大的

# include <stdio.h>
# include <string.h>

int main(void)
{
	int t, i, j, d, d1, q;
	int c, c1;
	int a1[2000], a2[2000];
	char a[1001], b[1001];
	scanf("%d", &t);
	while (t --)
	{
		memset(a1, 0, sizeof(a1));
		memset(a2, 0, sizeof(a2));
		scanf("%s %s", a, b);
		d = strlen(a), d1 = strlen(b);
		c = 0;
		for (i = 0; i < d; i ++)
		{
			if (a[i] == '1')
			{
				a[i] = '0';
				for (j = 0; j < d; j ++)
					a1[c] = a1[c]*2 + (a[j] - '0');
				c ++;
				a[i] = '1';
			}
			else
			{
				a[i] = '1';
				for (j = 0; j < d; j ++)
					a1[c] = a1[c]*2 + a[j] - '0';
				c ++;
				a[i] = '0';
			}
		}
		c1 = 0;
		for (i = 0; i < d1; i ++)
		{
			if (b[i] == '1')
			{
				b[i] = '0';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '2';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '1';
			}
			else if (b[i] == '0')
			{
				b[i] = '1';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '2';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '0';
			}
			else if (b[i] == '2')
			{
				b[i] = '0';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '1';
				for (j = 0; j < d1; j ++)
					a2[c1] = a2[c1]*3 + b[j] - '0';
				c1 ++;
				b[i] = '2';
			}
		}
		q = 0;
		for (i = 0; i < c; i ++)
		{
			for (j = 0; j < c1; j ++)
				if (a1[i] == a2[j])
				{
					printf("%d\n", a2[j]);
					q = 1;
					break;
				}
			if (q == 1)
			break;
		}	
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/liu344439833/article/details/80182564