7-1 英文单词排序(25 分)

7-1 英文单词排序(25 分)

本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。

输入格式:

输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。

输出格式:

输出为排序后的结果,每个单词后面都额外输出一个空格。

输入样例:

blue
red
yellow
green
purple
#

输出样例:

red blue green yellow purple
#include<stdio.h>
#include<string.h>
int main(void)
{
	char input[21][11] = { '\0' };
	char snap[11] = { '\0' };
	int i = 0;
	while (1) {
		scanf("%s", input[i]);
		if (input[i][0] == '#')
			break;
		i++;
	}
	input[i][0] = '\0';
	int len = i;
	int j = 0;
	for (i = 0; i < len; i++)
	{
		for (j = 1; j < len - i; j++)
		{
			if (strlen(input[j - 1]) > strlen(input[j]))
			{
				strcpy(snap, input[j - 1]);
				strcpy(input[j - 1], input[j]);
				strcpy(input[j], snap);
			}
 		}
	}
	for (i = 0; i < len; i++)
		printf("%s ", input[i]);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/mathew_leung/article/details/80382098