Roadblocks POJ - 3255 (次段路)

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers:  N and  R 
Lines 2..  R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length  D (1 ≤  D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node  N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)


 
 
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;

const int inf = 0x3f3f3f3f;

struct node{
	int to,v,Next;
}side[4000006];

int head[6000];
int len = 0;

void add(int x,int y,int v)
{
	side[len].to = y;
	side[len].v = v;
	side[len].Next = head[x];
	head[x] = len++;
}

struct Node{
	int x,t,d;
	bool operator <(const Node nd) const
	{
		return d > nd.d;  // !!!!
	}
};
int dis[6000][2];
int mk[6000][2];

void Dijstrea()
{
	memset(dis,63,sizeof(dis));
	dis[1][0] = 0;                   // !!!!
	priority_queue <Node> pq; 
	Node tmp;
	tmp.x = 1;
	tmp.d = 0;
	tmp.t = 0;
	pq.push(tmp);
	while(pq.size())
	{
		tmp = pq.top();
		pq.pop();
		int x = tmp.x;
		int t = tmp.t;
		int d = tmp.d;
		if(mk[x][t]) continue;          
		mk[x][t] = 1;
		for(int i = head[x]; i!=-1; i=side[i].Next)
		{
			int y = side[i].to;
			int v = side[i].v;
			if(dis[y][0] > d + v)
			{		
				dis[y][1] = dis[y][0];
				dis[y][0] = d + v;
				Node nd;
				nd.x = y;
				nd.d = dis[y][0];
				nd.t = 0;
				pq.push(nd);
				nd.d = dis[y][1];
				nd.t = 1;
				pq.push(nd);
			}	
			else if(dis[y][0] != d + v&&dis[y][1] > d + v)                //!!!!!
			{
				dis[y][1] = d + v;
				Node nd;
				nd.x = y;
				nd.d = dis[y][1];
				nd.t = 1;
				pq.push(nd);
			}
		}
	}
}

int main()
{
    int n,r;
    scanf("%d%d",&n,&r);
    len = 0;
    memset(head,-1,sizeof(head));
    for(int i = 0; i < r; i++)
    {
    	int x,y,v;
    	scanf("%d%d%d",&x,&y,&v);
    	add(x,y,v);
    	add(y,x,v);
    }
    
    Dijstrea();
    int ans = dis[n][1];
    cout << ans <<endl;
	return 0;
}


猜你喜欢

转载自blog.csdn.net/sunmoonvocano/article/details/79514213
今日推荐