F - Dungeon Master(SDUT 2017算法训练赛 -bfs三维)

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).

Trapped!

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int l,r,c;
char mmp[35][35][35];
int to[6][3]= {{0,1,0},{0,0,1},{0,-1,0},{0,0,-1},{1,0,0},{-1,0,0}};
struct node
{
    int x,y,z;
    int step;
} start;
queue<node>que;
int bfs()
{
    node temp1,temp2;
    start.step=0;
    temp1=start;
    que.push(temp1);
    mmp[temp1.x][temp1.y][temp1.z]='#';
    while(!que.empty())
    {
        for(int i=0; i<6; i++)
        {
            temp2.x=que.front().x+to[i][0];
            temp2.y=que.front().y+to[i][1];
            temp2.z=que.front().z+to[i][2];
            if(temp2.x<0||temp2.y<0||temp2.z<0||temp2.x>=l||temp2.y>=r||temp2.z>=c)
                continue;
            else if(mmp[temp2.x][temp2.y][temp2.z]!='#')
            {
                temp2.step=que.front().step+1;
                if(mmp[temp2.x][temp2.y][temp2.z]=='E')
                return temp2.step;
                que.push(temp2);
                mmp[temp2.x][temp2.y][temp2.z]='#';
            }
        }
        que.pop();
    }
    return -1;
}
int main()
{
    while(cin>>l>>r>>c)
    {
        if(l==0&&r==0&&c==0)
            break;
        for(int i=0; i<l; i++)
            for(int j=0; j<r; j++)
                for(int k=0; k<c; k++)
                {
                    cin>>mmp[i][j][k];
                    if(mmp[i][j][k]=='S')
                        start.x=i,start.y=j,start.z=k;
                }
        if(bfs()==-1)
            cout<<"Trapped!"<<endl;
        else
            cout<<"Escaped in "<<bfs()<<" minute(s)."<<endl;
            while(!que.empty())
            que.pop();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/beposit/article/details/80795959