poj 1325 Machine Schedule(二部图最小点覆盖集 最大匹配 匈牙利算法)(简单)

Machine Schedule
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13115   Accepted: 5596

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

附上一篇较好的博客--匈牙利算法(DFS增广)http://blog.csdn.net/kaisa158/article/details/48718403

代码:

//292K	32MS
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 105
int nx,ny;
int jobnum;//作业个数
int g[maxn][maxn];
int ans;//最大匹配数
int sx[maxn],sy[maxn];//标明顶点是否被访问过
int cx[maxn],cy[maxn];得到的匹配情况

int path(int u)
{
    sx[u]=1;
    int v;
    for(v=1;v<=ny;v++)
    {
        if(g[u][v]>0&&(!sy[v]))
        {
            sy[v]=1;
            if(!cy[v]||path(cy[v]))
            {
                cx[u]=v;
                cy[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

int solve()
{
    ans=0;
    int i;
    memset(cx,0,sizeof(cx));memset(cy,0,sizeof(cy));
    for(i=1;i<=nx;i++)
    {
        if(!cx[i])
        {
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            ans+=path(i);
        }
    }
    return 0;
}

int main()
{
    int i,j,k,m;
    while(cin>>nx)
    {
        if(nx==0)break;
        cin>>ny>>jobnum;
        memset(g,0,sizeof(g));
        for(k=0;k<jobnum;k++)
        {
            cin>>m>>i>>j;
            g[i][j]=1;
        }
        solve();
        cout<<ans<<endl;
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/kaisa158/article/details/48718355