poj 2387 最短路Dijkstra

简单的水题,之前做过的,只不过那个时候很懵懂。哈哈哈所以一直写不出来,我也是非常的菜的,现在也一样。。

题目链接 :点击打开链接

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题目大意:就是一个人在N这个点,他想很快的回到1这个点,求最短路径。。。

代码:

#include <iostream>
using namespace std;
const int maxn = 2000 + 10 ;
const int inf = 0xfffff;

int map[maxn][maxn];
int dis[maxn], vis[maxn];
int n , m;

void Dijkstra (){
    for (int i = 1; i <= n; i++){
        dis[i] = map[1][i];
        vis[i] = 0;
    }
    int k = 0; 
    for (int i = 1; i <= n; i++){
        int minx = inf ;
        for (int j = 1; j <= n; j++){
            if (!vis[j] && dis[j] < minx){
                minx = dis[j];
                k = j;
            }
        }
        vis[k] = 1 ;
        for (int j = 1; j <= n; j++){
            if (!vis[j] && dis[j] > dis[k] + map[k][j]){
                dis[j] = dis[k] + map[k][j] ;
            }
        }
    }
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> m >> n){
        for (int i = 1; i <= n; i++){
            for (int j = 1; j <= n; j++){
                map[i][j] = (i == j) ? 0 : inf;
            }
        }
        int a, b, c ;
        for (int i = 1 ; i <= m; i++){
            cin >> a >> b >> c ;
            if (map[a][b] > c){
                map[a][b] = map[b][a] = c ;
            }
        }
        Dijkstra();
        cout << dis[n] << endl ;
    }
    return 0;
}

再一次写这个题,还是错了两发,把T和N的含义搞反了。。。

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/79506858