poj 1338 Ugly Numbers

Description
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, …
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n’th ugly number.

Input
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

#include<cstdio>
#define maxn 1555
int UN[maxn]={0,1};
int Min(int a,int b){
    return a>b?b:a;
}
void GetUN(){
    int i,a2,a3,a5;
    a2=a3=a5=1;
    for(i=2;i<=1500;i++){
        UN[i]=Min(UN[a2]*2,Min(UN[a3]*3,UN[a5]*5));
        if(UN[i]==UN[a2]*2) a2++;
        if(UN[i]==UN[a3]*3) a3++;
        if(UN[i]==UN[a5]*5) a5++;
    }
}
int main(){
    GetUN();
    int n;
    while(scanf("%d",&n)==1,n){
        printf("%d\n",UN[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u012678352/article/details/80934520
今日推荐