[kuangbin带你飞]专题一 简单搜索-C Catch That Cow

C - Catch That Cow

  POJ - 3278 

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

//要么往前走,要么往后走,要么双倍走,如果n>=k,只能往后退
//基础bfs,但是能否放入队列,需要判断条件
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int n,k;
int a[200005];
queue <int> q;
int main()
{
    cin>>n>>k;
    memset(a,0,sizeof(a));
    q.push(n);
    if(n>=k)
    {
        printf("%d\n",n-k);
        return 0;
    }
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        if(x==k)   //如果到了终点就跳出
        {
            break;
        }
        if(a[x+1]==0&&x+1<=100000)
        {
            a[x+1]=a[x]+1;
            q.push(x+1);
        }
        if(a[x-1]==0&&x-1>0)
        {
            a[x-1]=a[x]+1;
            q.push(x-1);
        }
        if(a[x*2]==0&&x*2<=100000)//是100000不是200000,我也不知道为什么!那个好心人可以告诉我,QAQ
        {                         //200000就RE了
            a[x*2]=a[x]+1;
            q.push(x*2);
        }
    }
    printf("%d\n",a[k]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80918447