zoj 3938 Defuse the Bomb

(http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3938)

The bomb is about to explode! Please defuse it as soon as possible!

There is a display showing a number from 1 to 4 on the bomb. Besides this, there are 4 buttons under the display. Each button is labeled by a number from 1 to 4. The numbers on the buttons are always distinct.

There are 5 defusing stages in total. Pressing the correct button can progress the bomb to the next defusing stage. The number on the display and the number on each button may be different in different stages. The bomb will be defused only when all 5 defusing stages get passed. Pressing the incorrect button will cause the bomb to explode immediately. Be careful!

Here is the detailed bomb defusing manual. Button positions are ordered from left to right.

Stage 1:

If the display is 1, press the button in the second position.
If the display is 2, press the button in the second position.
If the display is 3, press the button in the third position.
If the display is 4, press the button in the fourth position.
Stage 2:

If the display is 1, press the button labeled “4”.
If the display is 2, press the button in the same position as you pressed in stage 1.
If the display is 3, press the button in the first position.
If the display is 4, press the button in the same position as you pressed in stage 1.
Stage 3:

If the display is 1, press the button with the same label you pressed in stage 2.
If the display is 2, press the button with the same label you pressed in stage 1.
If the display is 3, press the button in the third position.
If the display is 4, press the button labeled “4”.
Stage 4:

If the display is 1, press the button in the same position as you pressed in stage 1.
If the display is 2, press the button in the first position.
If the display is 3, press the button in the same position as you pressed in stage 2.
If the display is 4, press the button in the same position as you pressed in stage 2.
Stage 5:

If the display is 1, press the button with the same label you pressed in stage 1.
If the display is 2, press the button with the same label you pressed in stage 2.
If the display is 3, press the button with the same label you pressed in stage 4.
If the display is 4, press the button with the same label you pressed in stage 3.
Input
There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

There are 5 lines. Each line contains 5 integers D, B1, B2, B3, B4 indicating the number on the display and the numbers on the buttons respectively. The i-th line correspond to the i-th stage.

Output
For each test case, output 5 lines. The i-th line contains two integers indicating the position and the label of the correct button for the i-th stage.

Sample Input
1
4 2 1 3 4
2 2 4 3 1
4 3 1 4 2
4 3 4 2 1
2 3 1 2 4
Sample Output
4 4
4 1
3 4
4 1
2 1

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=5+7,INF=0x3f3f3f3f;
int b[N],p[N],l[N],pos[N]= {0,2,2,3,4};
int vis[N]= {0};
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        for(int i=1; i<=5; i++)
        {
            int d;
            scanf("%d",&d);
            for(int j=1; j<=4; j++)
                scanf("%d",&b[j]);
            if(i==2||i==3)
            {
                if(b[1]==4) p[i]=1;
                else if(b[2]==4) p[i]=2;
                else if(b[3]==4) p[i]=3;
                else p[i]=4;
            }
            if(i==1)
            {
                p[i]=pos[d];
                l[i]=b[pos[d]];
            }
            else
            {
                vis[b[1]]=1;
                vis[b[2]]=2;
                vis[b[3]]=3;
                vis[b[4]]=4;
                if(i==2)
                {
                    if(d==2||d==4) p[i]=p[1];
                    else if(d==3) p[i]=1;
                }
                else if(i==3)
                {
                    if(d==1) p[i]=vis[l[2]];
                    else if(d==2) p[i]=vis[l[1]];
                    else if(d==3) p[i]=3;
                }
                else if(i==4)
                {
                    if(d==1) p[i]=p[1];
                    else if(d==2) p[i]=1;
                    else p[i]=p[2];
                }
                else
                {
                    if(d==1) p[i]=vis[l[1]];
                    else if(d==2) p[i]=vis[l[2]];
                    else if(d==3) p[i]=vis[l[4]];
                    else p[i]=vis[l[3]];
                }
                l[i]=b[p[i]];
            }
            printf("%d %d\n",p[i],l[i]);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/80468990
ZOJ