UESTC Training for Summer selection C

C · m-ary Partitions

A partition of an integer n is a set of positive integers whichsum to n, typically written indescending order. For example:

10 = 4+3+2+1

A partition is m-ary ifeach term in the partition is a power of m.For example, the 3-ary partitions of 9 are:

9

3+3+3

3+3+1+1+1

3+1+1+1+1+1+1

1+1+1+1+1+1+1+1+1

Write aprogram to find the number of m-arypartitions of an integer n.

Input

 

Thefirst line of input contains a single decimal integer P, (1 £ P £ 1000), which is thenumber of data sets that follow. Each data set should be processed identicallyand independently.

Each data set consists of a single line of input. The line containsthe data set number, K, followed by the base of powers, m, (3<= m <= 100), followed by a space, followed by the integer,

n, (3 <= n <= 10000), for which the number of m-ary partitions is to be found.

Output

 

Foreach data set there is one line of output. The output line contains the dataset number, K, a space, and the number of m-ary partitions of n.The result should fit in a 32-bit unsigned integer.

Sample Input

Sample Output

5

1 3 9

2 3 47

3 5 123

4 7 4321

5 97 9999

1 5

2 63

3 75

4 144236

5 111

题意:给定 n,m,求n 的 m元划分。
思路:dp。

dp[ n ][ k ]表示 和为 n ,最大不超过 m^k 的划分方案;

转移方程: dp[ n ][ k ]=dp[ n ][ k-1 ]+dp[ n -m^k ][ k ].

就是完全背包的变形。

然后用滚动数组优化:

dp[ n ]=dp[ n ]+dp[ n- k ];

记得初始化时候, dp[ n ]=1,因为n 总可以分成 n 个 1 。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
#define maxn 200005
#define inf 0x3f3f3f3f
#define ii 0x3f
const int mod = 1001113;


ll read() {
	ll x = 0, f = 1;
	char ch = getchar();
	while (ch < '0' || ch > '9') {
		if (ch == '-') {
			f = -1;

		}
		ch = getchar();
	}
	while (ch >= '0'&&ch <= '9') {
		x = x * 10 + ch - '0';
		ch = getchar();
	}
	return x * f;
}

ll quickpow(ll a, ll b) {
	ll ans = 1;
	while (b > 0) {
		if (b % 2)ans = ans * a;
		b = b / 2;
		a = a * a;
	}
	return ans;
}
//char s[maxn];

int gcd(int a, int b) {
	return b == 0 ? a : gcd(b, a%b);
}

int dp[maxn];
int main() {
	ios::sync_with_stdio(false);
	int t;
	cin >> t;
	while (t--) {
		memset(dp, 0, sizeof(dp));
		int a, b, n;
		cin >> a >> b >> n;
		int maxx = 0;
		while (quickpow(b, maxx + 1) <= n)maxx++;
		for (int i = 0; i <= n; i++) {
			dp[i] = 1;
		}
		for (int i = 1; i <= maxx; i++) {
			int q = quickpow(b, i);
			for (int j = q; j <= n; j++) {
				dp[j] = dp[j] + dp[j - q];
			}
		
		}
		cout << a << ' ' << dp[n] << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40273481/article/details/80809061
今日推荐