POJ3050 Hopscotch【DFS+暴力】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5258   Accepted: 3460

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.  

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).  

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).  

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:  
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source


问题链接POJ3050 Hopscotch

问题简述:(略)

问题分析

  这个问题用暴力法来解决,DFS既是一种策略也是暴力。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:
/* POJ3050 Hopscotch */

#include <iostream>
#include <set>
#include <stdio.h>

using namespace std;

const int N = 5;
const int K = 6;
const int D = 4;

int drow[] = {-1, 0, 1, 0};
int dcol[] = {0, 1, 0, -1};

int a[N][N];
set<int> s;

void dfs(int row, int col, int k, int v)
{
    if(k == K)
        s.insert(v);
    else {
        for(int i = 0; i < D; i++) {
            int nextrow = row + drow[i];
            int nextcol = col + dcol[i];
            if(0 <= nextrow && nextrow < N && 0 <= nextcol && nextcol < N) {
                k++;
                dfs(nextrow, nextcol, k, v * 10 + a[nextrow][nextcol]);
                k--;
            }
        }
    }
}

void solve()
{
    for(int i = 0; i < N; i++)
        for(int j = 0; j < N; j++)
            dfs(i, j, 1, a[i][j]);

    printf("%d\n", (int)s.size());
}

int main()
{
    for(int i = 0; i < N; i++)
        for(int j = 0; j < N; j++)
            scanf("%d", &a[i][j]);

    solve();

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80963040