HDU 2594 KMP next数组

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12357    Accepted Submission(s): 4280


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
 
  
clinton homer riemann marjorie
 

Sample Output
 
  
0 rie 3
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2595 2596 2597 2598 2599 


这题就是把两个串联合一下 特判一下和之前分开的两个长度进行比较 

输出Next[len]就可以了

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
using namespace std;
int len;
const int MAX_N = 2000024;
int Next[MAX_N];
void getnext(string mo){
     int i=0,j=-1;
     while(i<len){
        if(j==-1||mo[i]==mo[j]) {++i,++j,Next[i]=j;}
        else j = Next[j];
     }
     return ;
}
int main(){
    string str_1,str_2,str;
    while(cin>>str_1){
        cin>>str_2;
        int len1 =str_1.length(),len2=str_2.length();
        str=str_1+str_2;
        len = str.length();
        Next[0] = -1;
        getnext(str);
        if(Next[len]>min(len1,len2)) Next[len] = min(len1,len2);
        if(Next[len]==0) cout<<"0"<<"\n";
        else cout<<str_1.substr(0,Next[len])<<" "<<Next[len]<<endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80992309