2016山东ACM省赛B 3561Fibonacci

Fibonacci

Problem Description

Fibonacci numbers are well-known as follow:

 

Now given an integer N, please find out whether N can be represented as the sum of several Fibonacci numbers in such a way that the sum does not include any two consecutive Fibonacci numbers.

Input

Multiple test cases, the first line is an integer T (T<=10000), indicating the number of test cases.

Each test case is a line with an integer N (1<=N<=10^9).

Output

One line per case. If the answer don’t exist, output “-1” (without quotes). Otherwise, your answer should be formatted as “N=f1+f2+…+fn”. N indicates the given number and f1, f2, … , fn indicating the Fibonacci numbers in ascending order. If there are multiple ways, you can output any of them.

Example Input

4
5
6
7
100

Example Output

5=5
6=1+5
7=2+5
100=3+8+89

#include <iostream>
using namespace std;
int f[45]={1,1,2,3,5,8,13,21,34,55,89,144,233,377,610,987,1597,2584,4181,6765,10946,17711,28657,46368,75025,121393,196418,317811,514229,832040,1346269,2178309,3524578,5702887,9227465,14930352,24157817,39088169,63245986,102334155,165580141,267914296,433494437,701408733,1134903170};
//斐波那契数列打表到10^9,递归求的话可能会超时
int a[50];//存放加数

int main()
{
    int t,n,k;
    cin>>t;
    while(t--)
    {
        cin>>n;
        k=n;
        int flag=0;
        for(int i=45;i>=1;i--)
        {
            if(f[i]<=n)
            {
                a[flag++]=f[i];
                n=n-f[i];
            }
        }
        if(n==0)
        {
            cout<<k<<"=";
            for(int i=flag-1;i>=1;i--)
            {
                if(i==flag-1)cout<<a[i];  //第一个
                else cout<<"+"<<a[i];
            }
            cout<<endl;
        }
        else cout<<"-1"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qlu_minoz/article/details/80148348