poj-3268-Silver Cow Party

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions:26681   Accepted: 12188

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

题目大意有n个农场,m条路,并且在X号农场开party。现在在除了X号农场的其他农场,都有牛来X号农场开party,party结束以后就各回各家,当然,走的都是最短路。求这n - 1只牛中往返的最大的最短路。

思路:先计算x农场到其他农场用的最短时间,在枚举其他农场到x农场的最短时间,记录下最大来回时间即可。的确,但是会超时,所以我们要想办法把枚举过程的复杂度降下来。  这里可以采用置换矩阵,因为是路径时单向的,我们交换 map[i][j] 与 map[j][i] 的值,那么枚举过程就变成了求x到其他农场的最短时间;

代码:

#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 99999999
int e[1001][1011],book[1001],dis[1001],way[1010];
int n;
void dijk(int x)
{
    int i,j,k,minx,u,v;
    for(i=1; i<=n; i++)
    {
        dis[i]=e[x][i];
        book[i]=0;
    }
    book[x]=1;
    for(i=1; i<=n; i++)
    {
        minx=inf;
        for(j=1; j<=n; j++)
        {
            if(book[j]==0&&dis[j]<minx)
            {
                minx=dis[j];
                u=j;
            }
        }
        book[u]=1;
        for(v=1; v<=n; v++)
        {
            if(e[u][v]<inf)
            {
                if(dis[v]>dis[u]+e[u][v])
                    dis[v]=dis[u]+e[u][v];
            }
        }
    }
}
int main()
{
    int m,x;
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {
        int i,j,t1,t2,t3,ans=0;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i!=j)
                    e[i][j]=inf;
                else
                    e[i][j]=0;
            }
        }
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            if(e[t1][t2]>t3)
                e[t1][t2]=t3;
        }
        dijk(x);
        for(i=1; i<=n; i++)
            way[i]=dis[i];
        for(i=1; i<=n; i++)
        {
            for(j=i+1; j<=n; j++)
            {
                int temp;
                temp=e[j][i];
                e[j][i]=e[i][j];
                e[i][j]=temp;
            }
        }
        dijk(x);
        for(i=1; i<=n; i++)
        {
            if(i!=x)
                ans=max(ans,way[i]+dis[i]);
//            printf("%d %d\n",way[i],dis[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/80076785