POJ 2387 Til the Cows Come Home (Dijkstra)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.


写题的时候一直没注意Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. 导致程序一直WA,跟别人程序对比才看出错误来


#include<cstring>
#include<iostream>
using namespace std;

#define MAX 99999999

int N,T;
int d1, d2, length;
int matrix[1005][1005];
int flag[1005];
int shortest[1005];
int temp;

void dijkstra()
{
    memset(flag, 0, sizeof(flag));
    for (int i = 1; i <= N; i++)
    {
        shortest[i] = matrix[1][i];
    }

    for (int i = 1; i <= N ; i++)
    {
        int k;
        temp = MAX;
        for (int j = 1; j <= N; j++)
        {
            if (flag[j] != 1 && shortest[j] < temp)
            {
                temp = shortest[j];
                k = j;
            }
        }

        if (temp == MAX)
            break;

        flag[k] = 1;

        for (int j = 1; j <= N; j++)
        {
            if (flag[j] != 1 && shortest[j]>shortest[k] + matrix[k][j])
            {
                shortest[j] = shortest[k] + matrix[k][j];
            }
        }
    }

    cout << shortest[N] << endl;
}


int main()
{

    cin >> T >> N;

    for (int i = 1; i <= N; i++)
    {
        for (int j = 1; j <= N; j++)
        {
            if (i==j)
            {
                matrix[i][i] = 0;
                continue;
            }
            matrix[i][j] = MAX;
        }
    }

    for (int i = 0; i < T; i++)
    {
        cin >> d1 >> d2 >> length;
        if(matrix[d1][d2]>length)
        {
            matrix[d1][d2] = length;
            matrix[d2][d1] = length;
        }

    }

    dijkstra();

    return 0;
}



猜你喜欢

转载自blog.csdn.net/shanwenkang/article/details/80962963