WOJ1406-Internet Service Providers

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T * (C - T * N). The problem is to compute T_optim, the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and T_optim are integer numbers.

输入格式

Each data set corresponds to an instance of the problem above and contains two integral numbers - N and C - with values in the range from 0 to 10^9. The input data are separated by white spaces, are correct, and terminate with an end of file. For each data set the program computes the value of T_optim according to the problem instance that corresponds to the data set.

输出格式

The result is printed on the standard output from the beginning of a line. There must be no empty lines on the output. An example of input/output is shown below.

样例输入

1 0
0 1
4 3
2 8
3 27
25 1000000000

样例输出

0
0
0
2
4
20000000


#include<stdio.h>
int main() {
	int n,c,r;
	while(scanf("%d %d",&n,&c)!=EOF) {
		if(n==0 || c==0) printf("0\n");
		else {
			float result=(float)(c/2.0/n);
			r=result;
			if(result-r<=0.5) printf("%d\n",r);
			else printf("%d\n",r+1);
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/lxq1071717521/article/details/77921638