WOJ1372-Sorting Algorithm

One of the fundamental problems of computer science is ordering a list of items. There?re a plethora of solutions to this problem, known as sorting algorithm. Some sorting algorithms are simple and intuitive, such as the bubble sort. Other, such as the heap sort are not simple, but produce lightening-fast results.


In the following is a list of some sorting algorithms . Of course, I can?t tell you to implement them here. You must use your own knowledge. 
________ 
Bubble sort 
Heap sort 
Insertion sort 
Merge sort 
Quick sort 
Selection sort 
Shell sort 
... 
________ 
My business here is to give you some numbers, and to sort them is your business. Attention, I want the smallest number at the top of the sorted list. 

输入格式

The input file will consist of series data sets. Each data set has two parts. The fist part contains two non-negative integers, n (1<=n<=100,000) and m (1<=m<=n), representing the total of numbers you will get interval of the output sorted list. The second part contains n positive integers. I am sure that each integer in this part will be less than 2,000,000,000.
The input is terminated by a line with two zeros.

输出格式

For one data set, you should output several numbers in ONE line. After you get the sorted list, you should output the first number of each m numbers, and you should print exact ONE space between two adjacent numbers. And please make sure that there should NOT be any blank line between outputs of two adjacent data sets.

样例输入

8 2
3
5
7
1
8
6
4
2
0 0

样例输出

1 3 5 7


#include<cstdio>
#include<algorithm>
using namespace std;
int num[100007];
int m,n;
int main(){
	int i,j,k;
	while(scanf("%d %d",&n,&m)!=EOF){
		if(n==0&&m==0)break;
		for(i=0;i<n;i++)
		scanf("%d",&num[i]);
		sort(num,num+n);
		for(i=0;i<n;i=i+m){
			if(i==0)
			printf("%d",num[i]);
			else
			printf(" %d",num[i]);
		}
		printf("\n");
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/lxq1071717521/article/details/77921620
今日推荐