POJ1936-All in All

       题目链接                                                                                            All in All

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 27352   Accepted: 11187

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002

思路:水题,直接看代码吧!

代码:

#include<iostream>
#include<cstdio> 
#include<cstring>
using namespace std;
int main()
{
	char str1[100200],str2[100200]; 
	int len2,i,j,sum,len1;
	while(cin>>str1>>str2){
		len2=strlen(str2),len1=strlen(str1);
		sum=i=j=0;
		for(;i<len2;i++){
			if(str1[j]==str2[i]){
				j++;
			}
			if(j==len1){//如果到达尾部,说明成立,直接退出
				printf("Yes\n");
				break;
			}
		}
		if(j!=len1) printf("No\n"); 
	}
} 

猜你喜欢

转载自blog.csdn.net/dadaguai001/article/details/81104655
ALL
今日推荐