Doing Homework again【HDU - 1789】

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

  • Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

  • Output

For each test case, you should output the smallest total reduced score, one line per test case.

  • Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
  • Sample Output
0
3
5
  • 题解:

          典型贪心。给了所有作业的截止时间和惩罚的扣分分值,求最小的扣分。根据题意,需优先完成分值大的作业。

以截止时间开始向前遍历,依次遍历,最后把无法完成的作业的分值加起来,输出。

  • 代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int a,b;
}edg[1010];
bool cmp(node x,node y)
{
    if(x.b==y.b)
        return x.a<y.a;
    return x.b>y.b;
}
int main()
{
    int t,n,m,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&edg[i].a);
        for(i=0;i<n;i++)
            scanf("%d",&edg[i].b);
        sort(edg,edg+n,cmp);
        int book[1010]={0};
        int ans=0;
        for(i=0;i<n;i++)
        {
            for(j=edg[i].a;j>=1;j--)
            {
                if(!book[j])
                {
                    book[j]=1;
                    break;
                }
            }
            if(j<=0)
                ans+=edg[i].b;
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/Meant_To_Be/article/details/81112023