Ants(POJ No. 1852)

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7418   Accepted: 3426

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

n只蚂蚁以每秒1cm的速度在长为Lcm的竿子上爬行。当蚂蚁爬到竿子的端点时就会掉落。由于竿子太细,两只蚂蚁相遇时,它们不能交错通过,只能各自反向爬回去。对于每只蚂蚁,我们知道它距离竿子左端的距离xi,但不知道它当前的朝向。请计算所有蚂蚁落下竿子所需的最短时间和最长时间。(1 ≤ L ≤ 10^6,1 ≤ n ≤ 10^6,0 ≤ xi ≤ L)

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

输入的第一行包含一个整数,表示后面的案例数。每种情况下的数据都以两个整数开始:长度(厘米)和蚂蚁的数量n。这两个数字后面是n个整数,表示每只蚂蚁的位置,作为从左侧测量的距离,没有特定的顺序。所有输入整数不大于1000000,它们由空格分隔。

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time. 

对于输入的每一种情况,输出由单个空格分隔的两个数字。第一个数是所有蚂蚁从杆子上掉下来的最早时间(如果它们的行走方向选择适当的话),第二个数字是最近的可能时间。

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

题解

两只蚂蚁相遇后朝反方向走,可以认为每只蚂蚁相对独立,保持原样交错而过

# include <cstdio>
# include <algorithm> 

using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int l, n;
		int maxl = 0, minl = 0;
		scanf("%d%d",&l,&n);
		while(n--)
		{
			int a;
			scanf("%d",&a);
			maxl = max(maxl, max(a, l-a));
			minl = max(minl, min(a, l-a));
		}
		printf("%d %d\n",minl, maxl);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39060776/article/details/81145257
今日推荐