C — Sequence

【题目】

C — Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

 

Problem Description

As we all know, Sister Ye is good at Graph Theory. Now he is intending to examine your Graph Theory level. Sister Ye would show you a degree sequence and ask you to find a simple graph that satisfies the sequence of degrees. Because the graph may be too large, you have to answer if such a graph exists or not only. In order to prevent you from guessing, Sister Ye will ask you more than once.

Input

The first line contains an integer T, the times Sister Ye ask you.

Each question will begin with a line contains an integer n, the size of sequence.
The following line contains a degree sequence a1,...,an.

Output

You should answer 'Y'(yes) or 'N'(no) for each question in one line.
1 ≤ T ≤ 50.
1 ≤ n ≤ 100000.
1 ≤ ai ≤ 10^9.

Sample Input

2

1

1

3

2 1 1

Sample Output

N

Y

Hint

loop:a loop is an edge that connects a vertex to itself. simple graph: a graph without loops and multiple edges between two vertexes. degree:the degree of a vertex in a graph is the number of edges connected to the vertex. degree sequence: An integer sequence of the degrees for each vertex in the graph.

【题解】

题意:给出度的序列问是否存在符合的简单图。

思路:  需满足:1.奇数度节点的个数是偶数   2.每个节点度数不超过n-1

【代码】

#include<bits/stdc++.h>
using namespace std;
long long a[100005];
main()
{
   int t,n,i,j;
   scanf("%d",&t);
   while(t--)
   {
       memset(a,0,sizeof(a));
       scanf("%d",&n);
       for(i=0;i<n;i++)
           scanf("%lld",&a[i]);
       long long maxn=0,c=0;
       for(i=0;i<n;i++)
       {
           maxn=max(maxn,a[i]);
           if(a[i]%2)
            c++;
       }
       if(c%2==0&&maxn<n)
         printf("Y\n");
       else
         printf("N\n");
   }
}

猜你喜欢

转载自blog.csdn.net/qq_41117236/article/details/81103942