【PAT】A1081. Rational Sum (20)

Description:
Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3


Sample Output 1:
3 1/3


Sample Input 2:
2
4/3 2/3


Sample Output 2:
2


Sample Input 3:
3
1/3 -1/6 1/8


Sample Output 3:
7/24

//NKW 甲级练习题1001
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
long long gcd(long long a, long long b){
	return b == 0 ? a : gcd(b,a%b);
}
typedef struct rational{
	long long numerator, denominator;
	rational(){
		numerator = 0;
		denominator = 1;
	}
}rational;
rational reduction(rational a){
	if (a.denominator < 0){
		a.numerator = -a.numerator;
		a.denominator = -a.denominator;
	}
	if (a.numerator == 0)
		a.denominator = 1;
	else{
		int d = gcd(abs(a.numerator), abs(a.denominator));
		a.numerator /= d;
		a.denominator /= d;
	}
	return a;
}
void printrational(rational a){
	if (a.denominator == 1)
		printf("%lld\n", a.numerator);
	else if (abs(a.numerator)>a.denominator)
		printf("%lld %lld/%lld\n", a.numerator / a.denominator, abs(a.numerator) % a.denominator, a.denominator);
	else
		printf("%lld/%lld\n", a.numerator, a.denominator);
}
rational sum, num;
int main(){
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%lld/%lld", &num.numerator, &num.denominator);
		sum.numerator = sum.numerator * num.denominator + num.numerator * sum.denominator;
		sum.denominator = sum.denominator * num.denominator;
		sum = reduction(sum);
	}
	printrational(sum);
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81103519