PAT-B1081 检查密码(15 分)

1081 检查密码(15 分)

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

分析:

用户的输入可能有空格,使用getline()获得密码的输入。所给用例没有这种情况:只有小数点,且长度不小于6.

代码:

#include <iostream>
#include <string>

using namespace std;

int main()
{
    int N, i, j;
    string pw;
    cin >> N;
    cin.get();
    for(i = 0; i < N; i++)
    {
        bool flag = true;
        getline(cin, pw);
        if(pw.size() < 6)
        {
            cout << "Your password is tai duan le.\n";
            flag = false;
            continue;
        }
        for(j = 0; j< pw.size(); j++)
            if(!isdigit(pw[j]) && !isalpha(pw[j]) && pw[j] != '.')
            {
                cout << "Your password is tai luan le.\n";
                flag = false;
                break;
            }
        if(!flag)
            continue;
        bool hasNum = true, hasAlpha = true;
        if(pw.find_first_of("0123456789") == string::npos)
            hasNum = false;
        for(j = 0; j < pw.size(); j++)
            if(isalpha(pw[j]))
            {
                flag = false;//find an alpha
                break;
            }
        if(flag)//find no alpha
            hasAlpha = false;
        if(hasAlpha ^ hasNum)
        {
            if(!hasAlpha)
                cout << "Your password needs zi mu.\n";
            else
                cout << "Your password needs shu zi.\n";
            continue;
        }
        cout << "Your password is wan mei.\n";
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38127801/article/details/81158273