Supermarket

问题 R: Supermarket

时间限制: 1 Sec  内存限制: 128 MB
提交: 10  解决: 3
[提交] [状态] [讨论版] [命题人:admin]

题目描述

A supermarket has a set Prod of products on sale. It earns a profit px for each product x⊆Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell  Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is 
An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. 
For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

输入

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct. 

输出

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

样例输入

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

样例输出

80
185

提示

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

[提交][状态]

给出商品的价值与截止日期,求最后可以卖出的最大价值

思路一:贪心,按价值从大到小排序,用一个数组标记某日期下是否有商品卖出

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const  int maxx=1e4+100;
const ll INF=1e9;
const int MOD=1e9+7;
int n;
struct node
{
    int pro,d;
}s[maxx];
bool cmp(node x,node y)
{
    return x.pro>y.pro;
}
bool vis[maxx];
int main()
{
    while(scanf("%d",&n)!=EOF){
        memset(vis,false,sizeof(vis));
        for (int i = 1; i <= n; ++i) {
            cin>>s[i].pro>>s[i].d;
        }
        sort(s+1,s+n+1,cmp);
        ll ans=0;
        for(int i=1; i<=n; i++){
            for(int j=s[i].d; j>0; j--){
                if(!vis[j]){
                    ans+=s[i].pro;
                    vis[j]=true;
                    break;
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

poj上是A了,可是我们oj t了,不过要是不t我也不会在思考(偷偷看题解)下一个更优化的办法了

思路二:在上一个思路的前提下,加上并查集,还是利用标记的思想(吧),具体分析还是看大佬的博客吧

代码:

//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
const  int maxx=1e4+100;
const ll INF=1e9;
const int MOD=1e9+7;
int n;
struct node
{
    int pro,d;
}s[maxx];
bool cmp(node x,node y)
{
    return x.pro>y.pro;
}
int f[maxx];
int findd(int x)
{
    if(f[x]==-1)  return x;
    return f[x]=findd(f[x]);
}
int main()
{
    while(scanf("%d",&n)==1){
        memset(f,-1,sizeof(f));
        for (int i = 1; i <= n; ++i) {
            scanf(" %d %d",&s[i].pro,&s[i].d);
        }
        sort(s+1,s+n+1,cmp);
        int ans=0;
        for(int i=1; i<=n; i++){
            int v=findd(s[i].d);
            if(v>0){
                ans+=s[i].pro;
                f[v]=v-1;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

不知道oj为什么只有写成这样才A,输出超限了无数遍。。。

scanf("%d",&n)==1

猜你喜欢

转载自blog.csdn.net/renzijing/article/details/81153245