ZOJ 3758

Singles' Day(or One's Day), an unofficial holiday in China, is a pop culture entertaining holiday on November 11 for young Chinese to celebrate their bachelor life. With the meaning of single or bachelor of number '1' and the huge population of young single man. This festival is very popular among young Chinese people. And many Young bachelors organize parties and Karaoke to meet new friends or to try their fortunes that day.

On Singles' Day, a supermarket has a promotional activity. Each customer will get a ticket on which there are two integers b and N, representing an integer M that only contains N digits 1 using b as the radix. And if the number M is a prime number, you will get a gift from the supermarket.

Since there are so many customers, the supermarket manager needs your help.

Input
There are multiple test cases. Each line has two integers b and N indicating the integer M, which might be very large. (2 >= b >= 16, 1 >= N >= 16)

Output
If the customer can get a gift, output "YES", otherwise "NO".

Sample Input
3 3
2 4
2 1
10 2

Sample Output
YES
NO
NO
YES

Hint
For the first sample, b=3, N=3, so M=(111)3, which is 13 in decimal. And since 13 is a prime number, the customer can get a gift, you should output "YES" on a line.

#include<string.h>
#include<stdio.h>
#include<algorithm>
bool prim(int n){
	if(n==1){
		return false;
	}
	for(int i=2; i*i<=n; i++)
		if(n%i == 0)
			return false;
	return true;
}

int main()
{
    int mul,i,b,N,sum;//b进制,N个1 
    scanf("%d%d",&b,&N);
    sum = 1;
    mul = 1;
    for(i=1;i<N;i++){
    	mul *= b; 
    	sum += mul;
	}
	if(prim(sum)){
		printf("YES\n");
	} else{
		printf("NO\n");
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u013862444/article/details/81149275
ZOJ