HDU 5323 Solve this interesting problem(DFS)

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3297    Accepted Submission(s): 1058


 

Problem Description

Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru.
- If Lu=Ru, u is a leaf node. 
- If Lu≠Ru, u has two children x and y,with Lx=Lu,Rx=⌊Lu+Ru2⌋,Ly=⌊Lu+Ru2⌋+1,Ry=Ru.
Here is an example of segment tree to do range query of sum.



Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R.

 

Input

The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015

 

Output

For each test, output one line contains one integer. If there is no such n, just output -1.

 

Sample Input

 

6 7 10 13 10 11

 

Sample Output

 

7 -1 12

题意:给你一个区间[l,r],让你找一个最小的n,在[0,n]的二分查找树中存在此区间[l,r]。若找不到n输出-1。

思路:如果对二分或者线段树理解透彻的话,这道题就很简单了。dfs构造产生此区间的上一个区间(共四种情况),

注意性质:r>=2*l(其实是严格大于),然后注意l==r的情况就可以了。

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
ll l,r,ans;
void dfs(ll l,ll r)
{
    if(l==0){ans=min(ans,r);return;}
    if(l<0)return;
    if(r-2*l>=0)return;
    dfs(2*(l-1)-r,r);
    dfs(2*(l-1)-r+1,r);
    if(l!=r)dfs(l,2*r-l);
    dfs(l,2*r-l+1);
}
int main()
{
    while(scanf("%lld%lld",&l,&r)!=EOF)
    {
        ans=inf;
        dfs(l,r);
        if(ans!=inf)printf("%lld\n",ans);
        else puts("-1");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lsd20164388/article/details/81140947
今日推荐