C - Monkey and Banana (DAG模型题,简单的dp)

C - Monkey and Banana

 


A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 这道题可以看成DAG模型去做,是一道DAG求最长路问题,首先通过进行长方体的一个保存,然后用sort进行排序, 遍历来得到答案。
代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;

struct node
{
    int l,w,h;
}a[100];

bool cmp(node a,node b)
{
    if(a.l == b.l)
    {
        if(a.w == b.w)
            return a.h>b.h;
        return a.w > b.w;
    }
    return a.l > b.l;
}
void max1(int &a,int &b,int &c)
{
    if(a > b)
    {
        int tmp = a; a = b; b = tmp;
    }
    if(a > c)
    {
        int tmp = a;a = c;c = tmp;
    }
    if(b > c)
    {
        int tmp = b; b = c; c = tmp;
    }
    return ;
}
int max(int a,int b)
{
    return a>b?a:b;
}
int dp[1000];
int main()
{
    int t = 1;
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < n; i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            max1(x,y,z);
            a[i].l = y; a[i].w = x; a[i].h = z;
            a[n+i].w = x; a[n+i].l = z; a[i+n].h = y;
            a[2*n+i].w = y; a[2*n+i].l = z; a[2*n+i].h = x;
            //printf("%d %d %d\n",a[i+2*n].l,a[i+2*n].w,a[i+2*n].h);
        }
        sort(a,a+3*n,cmp);
        //for(int i = 0; i < 3*n; i++)
          //  printf("%d %d %d\n",a[i].w,a[i].l,a[i].h);
        //head.l = a[0].l;head.w = a[0].w;head.h = a[i].h;head.brotree = NULL;
        int max2 = -1;
        for(int i = 3*n-1; i >= 0; i--)
        {
            for(int j = i + 1; j <= 3*n; j++)
            {
                if(a[i].l > a[j].l && a[i].w > a[j].w)
                {
                    dp[i] = max(dp[i],dp[j]+a[i].h);
                    //printf("%d\n",dp[i]);
                    if(max2 < dp[i])
                       max2 = dp[i];
                }
            }
        }
        printf("Case %d: maximum height = %d\n",t++,max2);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_39996728/article/details/80148805