Layout POJ - 3169(差分约束+SPFA)

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

题意:

一共有n头牛,有ml个关系好的牛的信息,有md个关系不好的牛的信息,对应输入的第一行的三个元素,接下来ml行,每行三个元素A,B,D,表示A牛和B牛相距不希望超过D,接下来md行,每行三个元素A,B,D表示A牛和B牛的相距至少要有D才行。求1号牛和n号牛的最大距离,如果距离无限大输出-2,如果无解输出-1。

思路:设dis [ x ] 为x 到 0 位置的距离,  v 的标号大于 u

我们要求 dis [ n ] -  dis [ 1 ] <=x   即,x是n号牛与1号牛的最大距离

对于ml的关系好的牛有:    dis [ v ] - dis [ u ] <= w;     ------->       dis [ v ] <=   dis [ u ]  +  w;    建一条从u到v,权值为   w  边

对于md的关系差的牛有:   dis [ v ] - dis [ u ] >= w;    --------->     dis [ u ] <=   dis [ v ]  -  w;     建一条从v到u,权值为  -w  边

则:我们的目标 是 dis [ v ] <=   dis [ u ]  +  x;   若碰到  dis [ v ]    >   dis [ u ]  +  x  边进行松弛

因此,应该跑最短路

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 1005;
const int M = 1000005;
struct node{
	int v;
	int w;
	int next;
}edge[M*2];
int id,head[N];
int dis[N],vis[N],vn[N];
int n,a,b;
void init(){
	id=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w){
	edge[id].v=v;
	edge[id].w=w;
	edge[id].next=head[u];
	head[u]=id++;
}
void SPFA(){
	memset(dis,Inf,sizeof(dis));
	memset(vis,0,sizeof(vis));
	queue<int>p;
	p.push(1);
	vis[1]=1;
	dis[1]=0;
	vn[1]=1;
    while(!p.empty()){
    	int u=p.front();
    	p.pop();
    	vis[u]=0;
    	if(vn[u]>n){
    		printf("-1\n");
    		return;
		}
    	for(int i=head[u];i!=-1;i=edge[i].next){
    		int v=edge[i].v;
    		int w=edge[i].w;
    		if(dis[v]>dis[u]+w){
    			dis[v]=dis[u]+w;
    			if(!vis[v]){
    				p.push(v);
    				vis[v]=0;
    				vn[v]++;
				}
			}
		}
	}
	int ans=dis[n];
	if(ans==Inf) printf("-2\n");
	else printf("%d\n",dis[n]);
}
int main(){
	while(~scanf("%d%d%d",&n,&a,&b)){
		init();
		for(int i=0;i<a;i++){
			int u,v,w;
		    scanf("%d%d%d",&u,&v,&w);
		    if(u>v) swap(u,v);
		    add(u,v,w);
		}
		for(int i=0;i<b;i++){
			int u,v,w;
		    scanf("%d%d%d",&u,&v,&w);
		    if(u>v) swap(u,v);
		    add(v,u,-w);
		}
		SPFA();
	}
    return 0;
}

   

猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/81155802
今日推荐