2018 Multi-University Training Contest 1.Maximum Multiple(整除运算)

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


 

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

 

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

 

Sample Input

 

3 1 2 3

 

Sample Output

 

-1 -1 1

解题思路:  1=\frac{1}{3 }+\frac{1}{3 }+\frac{1}{3}=\frac{1}{2}+\frac{1}{4}+\frac{1}{4}=\frac{1}{2}+\frac{1}{3}+\frac{1}{6}

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    long long T,n;
    scanf("%lld",&T);
    while(T--&&scanf("%lld",&n))
    {
        if(n%3==0) printf("%lld\n",n*n*n/27);
        else if(n%4==0) printf("%lld\n",n*n*n/32);
        else printf("-1\n");
    }
}

猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/81175827