并查集--More is better

More is better

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2


        
  

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
       
 

测试样例分析:

#include<stdio.h>
#define MAX 10000001

int fa[MAX],num[MAX];
//fa数组是用来存放小队长的
//num数组是用来存放i这位小队长底下有多少个人 
int maxx; //用来存放人数最庞大的一支队伍
 
int find(int x){//查询x的大队长 
	if(x==fa[x])
		return x;
	else
		return fa[x] = find(fa[x]);
}
 
void merge(int x,int y){
	int fx = find(x);//找到x的大队长 
	int fy = find(y);//找到y的大队长 
	if(fx!=fy){
		fa[fx] = fy;//若不是一个分队的,则将fx合并入fy 
		num[fy] += num[fx]; //将fy中的人数再加上新合并过来的人数 
		if(num[fy] > maxx)
			maxx = num[fy];
	}
}
 
 
int main(){
	int n;//n对关系 
	int x,y;//两个人x,y 
	while(scanf("%d",&n)!=EOF){//输入有多少对关系 
		if(n==0){//0对关系,只能有一个人留下 
			printf("1\n");
			continue;
		}
		for(int i = 1;i<MAX;i++){
		//初始化所有人都是没有关系的
		//num是用来表示i这个人手底下有多少人 
			fa[i] = i;
			num[i] = 1;
		}
		maxx = 0; //能留下的最大人数 
		for(int i = 0;i<n;i++){
			scanf("%d %d",&x,&y);
			merge(x,y);
		}
		printf("%d\n",maxx);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40626497/article/details/81153861