【hackerrank】-Day 3: Intro to Conditional Statements

30-conditional-statements
Objective
In this challenge, we’re getting started with conditional statements. Check out the Tutorial tab for learning materials and an instructional video!

Task
Given an integer, , perform the following conditional actions:

If is odd, print Weird
If is even and in the inclusive range of to , print Not Weird
If is even and in the inclusive range of to , print Weird
If is even and greater than , print Not Weird
Complete the stub code provided in your editor to print whether or not is weird.

Input Format

A single line containing a positive integer, .

Constraints

Output Format

Print Weird if the number is weird; otherwise, print Not Weird.

Sample Input 0

3
Sample Output 0

Weird
Sample Input 1

24
Sample Output 1

Not Weird
Explanation

Sample Case 0:
is odd and odd numbers are weird, so we print Weird.

Sample Case 1:
and is even, so it isn’t weird. Thus, we print Not Weird.


Current Buffer (saved locally, editable)

#!/bin/python3

import math
import os
import random
import re
import sys



if __name__ == '__main__':
    N = int(input())
    if N < 1 or N > 100:
        print('N < 1 or N > 100')
    if N % 2 != 0:
        print('Weird')
    # 说明需求是2到5之间的偶数打印Not Weird,包含2和5,所以注意是range(2, 6)
    if N % 2 == 0 and N in range(2, 6):
        print('Not Weird')
    # 说明需求是6到20之间的偶数打印Weird,包含6和20,所以注意是range(6, 21)
    if N % 2 == 0 and N in range(6, 21):
        print('Weird')
    if N % 2 == 0 and N > 20:
        print('Not Weird')

Congratulations!

You have passed the sample test cases. Click the submit button to run your code against all the test cases.

Testcase 0 Testcase 1
Input (stdin)
3
Your Output (stdout)
Weird
Expected Output
Weird

猜你喜欢

转载自blog.csdn.net/langhailove_2008/article/details/81176131