UVA 10820 交表 (欧拉函数简单应用)

When participating in programming contests, you sometimes face the following problem: You know how to calcutale the output for the given input values, but your algorithm is way too slow to ever pass the time limit. However hard you try, you just can’t discover the proper break-off conditions that would bring down the number of iterations to within acceptable limits. Now if the range of input values is not too big, there is a way out of this. Let your PC rattle for half an hour and produce a table of answers for all possible input values, encode this table into a program, submit it to the judge, et voila: Accepted in 0.000 seconds! (Some would argue that this is cheating, but remember: In love and programming contests everything is permitted). Faced with this problem during one programming contest, Jimmy decided to apply such a ’technique’. But however hard he tried, he wasn’t able to squeeze all his pre-calculated values into a program small enough to pass the judge. The situation looked hopeless, until he discovered the following property regarding the answers: the answers where calculated from two integers, but whenever the two input values had a common factor, the answer could be easily derived from the answer for which the input values were divided by that factor. To put it in other words:
Say Jimmy had to calculate a function Answer(x,y) where x and y are both integers in the range [1,N]. When he knows Answer(x,y), he can easily derive Answer(k∗x,k∗y), where k is any integer from it by applying some simple calculations involving Answer(x,y) and k. For example if N = 4, he only needs to know the answers for 11 out of the 16 possible input value combinations: Answer(1,1), Answer(1,2), Answer(2,1), Answer(1,3), Answer(2,3), Answer(3,2), Answer(3,1), Answer(1,4), Answer(3,4), Answer(4,3) and Answer(4,1). The other 5 can be derived from them (Answer(2,2), Answer(3,3) and Answer(4,4) from Answer(1,1), Answer(2,4) from Answer(1,2), and Answer(4,2) from Answer(2,1)). Note that the function Answer is not symmetric, so Answer(3,2) can not be derived from Answer(2,3).
Now what we want you to do is: for any values of N from 1 upto and including 50000, give the number of function Jimmy has to pre-calculate.
Input
The input file contains at most 600 lines of inputs. Each line contains an integer less than 50001 which indicates the value of N. Input is terminated by a line which contains a zero. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which indicates how many values Jimmy has to pre-calculate for a certain value of N.
Sample Input
2 5 0
Sample Output
3 19

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define ll long long
#define maxn 50005
#define ms memset
using namespace std;
/*
题目大意:给定两个数的上界,
要求计算二元组(x,y)的个数
二元组的要求是x与y互素。
(题目中总结出的性质)

这样递推关系就好找了,
f(n)=f(n-1)+euler(n)*2(二元组中如果有n参与则是关于n的欧拉函数计数,并且要增倍)
*/
int phi[maxn];
void get_table()
{
    memset(phi,0,sizeof(phi));
    for(int i=2;i<maxn;i++)
    {
        if(phi[i]) continue;
        for(int j=i;j<maxn;j+=i)
        {
            if(phi[j]==0) phi[j]=j;
            phi[j]-=phi[j]/i;
        }
    }
}
int n,ans[maxn];

int main()
{
    get_table();  ans[1]=1;
    for(int i=2;i<maxn;i++)  ans[i]=ans[i-1]+phi[i]*2;
    while(scanf("%d",&n)&&n)
        printf("%d\n",ans[n]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/81217930