简单枚举类型——植物与颜色(Java)

简单枚举类型——植物与颜色
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don’t know about the color purple.

Input
输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。
Output
输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don’t know about the color purple.

Sample Input

blue
yellow
purple

Sample Output

Bluebells are blue.
Sunflower are yellow.
I don’t know about the color purple.

Hint
请用枚举类型实现。
Source
lxh


import java.text.DecimalFormat;
import java.util.*;

import java.util.Scanner;

enum Color{
    red("Rose","red"),
    orange("Poppies","orange"),
    yellow("Sunflower","yellow"), 
    green("Grass","green"),
    blue("Bluebells","blue"),
    violet("Violets","violet");
    String name,color;
    Color(String name,String color){
        this.name = name;
        this.color = color;
    }
    public String toString() {
        return name+" are "+color+".";
    }
}

public class Main {
    public static void main(String args[]){
        Scanner input = new Scanner(System.in);
        int flag = 30;
        while(input.hasNext() && flag-- != 0) {
            String str = input.next();
            try {
                Color co = Color.valueOf(str);
                System.out.println(co.toString());
            }catch(Exception e) {
                System.out.println("I don't know about the color "+str+".");
            }

        }
        input.close();
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40014462/article/details/80070091