hdu-360(排序)

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1631    Accepted Submission(s): 823
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

Sample Input

 

1 1 1 2 2 3 3 5

 

Sample Output

 

1 2 3

 

Source

2018 Multi-University Training Contest 1

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

 

Statistic | Submit | Discuss | Note

心得:每三个点都不共线,只要从左向右一次找3个点,一直找下去就行了。

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
struct T{
    LL x,y,id;
};

bool cmp(T a,T b)
{
    if(a.x!=b.x) return a.x<b.x;
    else a.y<b.y; 
}

int main(void)
{
    int n;
    LL i,t;
    while(~scanf("%lld",&t))
    {
        while(t--)
        {
            T a[3003];
            scanf("%d",&n);
            for(i=1;i<=n*3;i++)
            {
                scanf("%lld%lld",&a[i].x,&a[i].y);
                a[i].id=i;
            }
            sort(a+1,a+n*3+1,cmp);
            for(i=1;i<=3*n;i+=3)
            {
                printf("%lld %lld %lld\n",a[i].id,a[i+1].id,a[i+2].id);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81347952
360