HDU1116Play on Words

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9812    Accepted Submission(s): 3351


 

Problem Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Source

Central Europe 1999

问题链接:HDU1116Play on Words

问题分析:此题为有向图,存在欧拉路径的充要条件是最多只有两个点的入度不等于出度:起点出度比入度大1,终点入度比出度大1。(或者每个点的入度等于出度)

程序说明:用并查集判断图是否连通,注意点的个数是26个字母出现的种类数

AC的C++程序:

#include<iostream>
#include<cmath>
#include<string>
#include<cstring>

using namespace std;

const int N=26;
int pre[N];
int in[N];
int out[N];

void init(int n)
{
	for(int i=0;i<=n;i++)
	  pre[i]=i;
}

int find(int x)
{
	int r=x;
	while(r!=pre[r])
	  r=pre[r];
	while(x!=pre[x]){
		int i=pre[x];
		pre[x]=r;
		x=i;
	}
	return r;
}

bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		if(fx>fy){
			int temp=fx;
			fx=fy;
			fy=temp;
		}
		pre[fx]=fy;
		return true;
	}
	return false;
}

int main()
{
	int t,n;
	string s;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		init(N);
		int a[26];//临时数组 
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		memset(a,0,sizeof(a));
		int cnt=0;
		while(n--){
			cin>>s;
			int u=s[0]-'a';
			int v=s[s.length()-1]-'a';
			out[u]++;
			in[v]++;
			a[u]=1;
			a[v]=1;
			if(join(u,v))
			  cnt++;
		}
		int ans=0;
		int sum=0;
		for(int i=0;i<N;i++)
		  sum+=a[i];
		if(cnt==sum-1){
			int num=0;
			for(int i=0;i<N;i++)
			  num+=abs(in[i]-out[i]);
			if(num<=2)
			  ans=1;
		}
		if(ans)
		  cout<<"Ordering is possible."<<endl;
		else
		  cout<<"The door cannot be opened."<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81327884