hdu6318(归并排序求逆序对)

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 636    Accepted Submission(s): 253

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

Output

For every test case, a single integer representing minimum money to pay.

Sample Input

3 233 666

1 2 3

3 1 666

3 2 1

Sample Output

0 3

Source

2018 Multi-University Training Contest 2

Recommend

chendu   |   We have carefully selected several similar problems for you:  6318 6317 6316 6315 6314 

Statistic | Submit | Discuss | Note

Home | Top Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2018 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.031200(s) query 6, Server time : 2018-07-26 09:54:22, Gzip enabled
Administration

注意*****这里不是序列翻转。起先题意读错一直不知道怎么做。

题意:给你长度为n的序列,我们要把他变成升序的序列,有两种办法;

1.序列中有多少个逆序对,每一个逆序对要花费x元,可以变成升序的序列。

2.翻转相邻的两个数,每翻转就要花费y元。

求最小的花费可以变成升序的序列。

解析:求出逆序对,归并排序法。归并是分成许多段,这些段我们可以求出相邻的两个元素翻转要y元。

ans要long long 防止溢出

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))

const int maxn = 100005;
ll ans;
int a[maxn],temp[maxn];
void merge(int l,int mid,int r)
{
    int i=l;
    int j=mid+1;
    int k=l;
    while(i<=mid&&j<=r)
    {
        if(a[j]>=a[i])
        {
            temp[k++]=a[i++];
        }
        else
        {
            ans+=mid-i+1;
            temp[k++]=a[j++];
        }
    }
    while(i<=mid)temp[k++]=a[i++];
    while(j<=r)temp[k++]=a[j++];
    for(i=l;i<=r;i++)a[i]=temp[i];
}
void merge_sort(int x,int y)
{
    if(x>=y)return ;
    int t=x+y>>1;
    merge_sort(x,t);
    merge_sort(t+1,y);
    merge(x,t,y);
}
int main()
{
    int n,x,y;
    while(~scanf("%d%d%d",&n,&x,&y))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        ans=0;
        merge_sort(0,n-1);
        printf("%lld\n",ans*min(x,y));
    }
 
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/81214678