集训笔记---队列应用(POJ NO.3253 Fence Rapair)小顶堆、优先队列

Fence Repair

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 60981   Accepted: 20112

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li(1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

priority_queue 对于基本类型的使用方法相对简单。他的模板声明带有三个参数:
priority_queue<Type, Container, Functional>
其中Type 为数据类型, Container 为保存数据的容器,Functional 为元素比较方式。
Container 必须是用数组实现的容器,比如 vector, deque 但不能用 list.
STL里面默认用的是 vector. 比较方式默认用 operator< , 所以如果你把后面俩个参数缺省的话,
优先队列就是大顶堆,队头元素最大,那么也就是说,如果将所有元素压入队列以后对头元素将是那个最大的元素;

而在本题中,所需要的情况却恰恰相反,那么就需要将queue的三个参数都写出来,并作出修改即将queue<int>改写为

queue<int, vector<int>, greater<int> >,经过处理以后,我们就得到了一个小顶堆,它的队头元素是所有元素中最小的那一个

AC代码

#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int MAX_N = 100010;
int l[MAX_N];
int main(void)
{
    int n, i;
    long long ans = 0;
    priority_queue<int, vector<int>, greater<int> > q;
    scanf("%d", &n);
    for(i = 0; i < n; i++)
    {
        scanf("%d", &l[i]);
        q.push(l[i]);
    }
    while(q.size() > 1)
    {
        int l1, l2;
        l1 = q.top();
        q.pop();
        l2 = q.top();
        q.pop();
        ans = ans + l1;
        ans = ans + l2;
        q.push(l1 + l2);
    }
    printf("%lld", ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zzuli_xiaomingke/article/details/81390153