Monkey and Banana(最长递增子序列变形)

 Monkey and Banana

 HDU - 1069 

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目:每一种都有无限多个,求堆起来的最大高度,堆起来的时候上面木块的长和宽必须小于下面的长和宽。

思路:把所有的长和宽列出来,按照最长递增子序列的方法做。

#include<map>
#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define maxn 100005
#define inf 0x3f3f3f3f
#define ll long long
#define mod 7
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct node{
    int a,b,c;
}d[maxn];
int l=0;
ll dp[maxn];
bool cmp(node n,node m){
    if(n.a==m.a)return n.b>m.b;
    return n.a>m.a;
}
int main(){
    int n,k=0;
    while(~scanf("%d",&n)&&n){
        k++;
        mem(dp,0);
        m1.clear();
        mem(d,0);
     int a,b,c;
     l=0;
     for(int i=0;i<n;i++){
        scanf("%d%d%d",&a,&b,&c);
            d[l].a=a;d[l].b=b;d[l++].c=c;
            d[l].b=a;d[l].c=b;d[l++].a=c;
            d[l].c=a;d[l].a=b;d[l++].b=c;
            d[l].a=a;d[l].c=b;d[l++].b=c;
            d[l].b=a;d[l].a=b;d[l++].c=c;
            d[l].c=a;d[l].b=b;d[l++].a=c;
        }
        sort(d,d+l,cmp);
        ll ans=0;
        for(int i=0;i<l;i++){
            dp[i]=d[i].c;
            for(int j=0;j<i;j++){
                if(d[i].a<d[j].a&&d[i].b<d[j].b){
                    dp[i]=max(dp[i],dp[j]+d[i].c);
                }
            }
            ans=max(ans,dp[i]);
        }
        cout<<"Case "<<k<<": maximum height = "<<ans<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/lpeaceminusone/article/details/81413665