Packets - poj1017 - 贪心

Packets

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 61675   Accepted: 20910

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

Central Europe 1996

题意:

输入1*1,2*2,…,6*6物品的个数,然后把他们装到6*6的盒子里,问最少装几个

思路:

6*6的物品需要一个盒子

5*5的和11个1*1用一个盒子

4*4的优先和2*2的用一个盒子,当2*2的没了时再和1*1的用一个盒子

3*3的

  • a[3]%4==0,3*3的不和别的公用
  • a[3]%4==1、2、3都是先考虑和2*2的共用

细心点~

代下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue> 
#include<vector>

using namespace std;
int a[10];

int scan(){
	int flag=0;
	for(int i=1;i<=6;i++){
		scanf("%d",&a[i]);
		if(a[i])flag=1;
	}
	return flag;
}

void solve(){
	int ans=a[6],tmp;
	ans+=a[5];
	a[1]-=a[5]*11;
	ans+=a[4];
	if(a[2]<5*a[4]){
		tmp=5*a[4]-a[2];//剩下tmp个2*2没用 
		a[1]-=tmp*4;
		a[2]=0;
	}
	else a[2]-=5*a[4];
	
	if(a[3]%4==0){
		ans+=a[3]/4;
	}
	else if(a[3]%4==1){
		ans+=(a[3]/4)+1;
		if(a[2]>0){
			if(a[2]>=5){
				a[2]-=5;
				a[1]-=7;
			}
			else {
				a[1]-=(27-a[2]*4);
				a[2]=0;
			}
		}
		else a[1]-=27;
	}
	else if(a[3]%4==2){
		ans+=(a[3]/4)+1;
		if(a[2]>0){
			if(a[2]>=3){
				a[2]-=3;
				a[1]-=6;
			}
			else{
				a[1]-=(18-a[2]*4);
				a[2]=0;
			}
		}
		else a[1]-=18;
		
	}
	else{
		ans+=(a[3]/4)+1;
		if(a[2]>0){
			a[2]-=1;
		    a[1]-=5;
		}
		else a[1]-=9;
	}
	
	if(a[1]<=0&&a[2]<=0){
		printf("%d\n",ans);
		return ;
	}
	
	else if(a[1]>0&&a[2]>0){
		tmp=a[2]%9; 
		ans+=a[2]/9+(a[2]%9?1:0);
		if(tmp==0){
			ans+=a[1]/36+(a[1]%36?1:0);
		}
		else {
			tmp=36-tmp*4;
		    a[1]-=tmp;
		    if(a[1]>0)ans+=a[1]/36+(a[1]%36?1:0);
		}
	}
	else if(a[1]>0&&a[2]<=0){
		ans+=a[1]/36+(a[1]%36?1:0);
	}
	else if(a[1]<=0&&a[2]>0){
		ans+=a[2]/9+(a[2]%9?1:0);
	}
	printf("%d\n",ans);
	return ;
}

int main(){
	while(scan()){
		solve();
	}
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81347703