动态规划特训:Charm bracelet(0-1背包,未使用滚动数组,超时)

简单0-1背包裸题,提示初学者一些需要注意的地方,按照正常的动态规划思路其实是一个二维动规题目,不过可以使用滚动数组优化为一维dp,祈祷节省空间的作用,本篇博文先介绍二维dp解法,该解法占用空间资源过多,许多时候无法满足oj平台空间限制的要求,因而建议直接使用优化后的一维dp。

dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i])   i>1

dp[1][j]=0                                                 j<w[i]

dp[1][j]=v[1]                                             j>=w[i]

加红部分虽然好像程序中不设置依然可以得到正确结果,不过监狱逻辑上的完整性建议还是设置一下。

同时注意代码中的一处注释!

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23
#include<stdio.h>
#include<string.h>
int dp[3501][13001];
int max(int a,int b)
{
	return a>b?a:b;
}
struct packet
{
	int w;
	int v;
}a[3501];
int main()
{
	int n,mw;
	scanf("%d%d",&n,&mw);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&a[i].w,&a[i].v);
	}
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<a[i].w;j++)                     //这一步一定要有,如果使用滚动数组法j反向求值可以省略,但是在这里是必须的。 
		{
			dp[i][j]=dp[i-1][j];
		}
		for(int j=a[i].w;j<=mw;j++)
		{
			dp[i][j]=max(dp[i-1][j],dp[i-1][j-a[i].w]+a[i].v);
		}
	}
	printf("%d\n",dp[n][mw]);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/mavises/article/details/81434554